Symptom
A Voice for Teams administrator receives this error when performing a Voice for Teams admin portal sync that includes a PBX sync:
- ERROR: Email address 'xxxxx.yyyyy@zzzzz.com' is duplicated on X users
Applies To
- 8x8 Voice for Microsoft Teams
- 8x8 Admin Console
- Voice for Teams Admin Portal
Resolution
Admin Console Email Duplication
- Follow the instructions in this article to download and review a CSV file report of users who have the 8x8 MS Teams license enabled in their 8x8 user profiles.
- Review the email addresses (in the CSV file's User.Email field) of those MS Teams-enabled users, to look for more than one entry of the same email address.
- If you find a user with more than one entry of the same email address (for which the MS Teams license is enabled), you must either change the email address(es) so that there is only one entry, or disable the additional MS Teams license(s) for the affected user(s). Save your changes.
- Finally, perform a full sync (click Sync Now) in the Voice for Teams admin portal to complete the process.
8x8 Service Issue
- First, follow the instructions in this article to download and review a CSV file report of users who have the 8x8 MS Teams license enabled in their 8x8 user profiles.
- Verify that there are no duplicate entries of email addresses (in the CSV file's User.Email field) for MS Teams-enabled users in the 8x8 Admin Console.
- If you find no duplicates of email addresses, create a case with 8x8 Support for this issue.
Cause
When a PBX Sync Now process is initiated in the 8x8 Voice for Teams admin portal, a verification is performed to ensure that email addresses are not duplicated in the 8x8 Admin Console. This applies only to 8x8 user profiles for which MS Teams integration licenses have been enabled.
If a duplication is detected, the sync process will terminate and the error will be displayed in the sync logs.
There are two likely causes for the issue:
Admin Console Email Duplication
- An 8x8 Admin Console administrator has added two or more Users and applied the same email address to the Email field in the user(s) profiles, and the MS Teams license has been enabled for those users. This typically happens (for example) when an administrator adds their own email address to more than one 8x8 user profile, enables the MS Teams license for those profiles, and then performs a Voice for Teams admin portal sync.
8x8 Service Issue
- This cause is extremely rare but has been noted: Multiple MS Teams licenses have been assigned to each of one or more user profiles on the 8x8 Admin Console backend. This is not visible in the 8x8 Admin Console.
- This issue may be caused when a user profile that has already had their MS Teams license enabled is effectively re-enabled by inclusion of the same user in a Bulk User upload of a CSV file into Admin Console. This has not yet been 100% confirmed, and ultimate root cause is still under investigation.