Unable to Log in to 8x8 Work for Mobile App on iPhone Using SSO

Updated: 12/19/2024

Symptom

When logging in to the 8x Work for Mobile app using SSO, it routes back to the username page and does not load the password page.

Applies To

  • 8x8 Work for Mobile
  • iOS

Resolution

Allow Third Party Cookies.
Safari Browser
  1. Go to settings on the mobile phone and not the 8x8 Work for Mobile.
  2. Select Apps.
  3. Locate and select Safari.
  4. Once it is opened, select Advanced.
  5. Disable the option where it says BLOCK ALL COOKIES.
  6. Log in to the 8x8 Work for Mobile.
Chrome Browser
  1. Open the crom app.
  2. At the bottom right, Tap MORE, marked as three dots.
  3. Select Settings.
  4. Go to Privacy and Security.
  5. Select Third Party Cookies.
  6. Select ALLOW THIRD PARTY COOKIES.
  7. Log in to the 8x8 Work for Mobile.

Cause

Cookies are blocked preventing redirection to the password page.