Inspect Saved Configuration Error When Saving Line Key Configuration in 8x8 Admin Console

Updated: 10/24/2024

Symptom

An error banner with the following message is displayed when attempting to save Line Key Configuration:
Error while saving line key configuration. Failed and creating power key. Please inspect the saved configuration.
  
LineKeyConfigurationError.png

Applies To

  • Admin Console
  • Desk Phone
  • Line Keys

Resolution

Remove the existing line keys and create new ones in their place:
  1. Access the 8x8 Admin Console.
  2. Click the Users icon.
  3. Locate the user profile experiencing the error.
  4. Click on the pencil icon on the right to Edit the user.
  5. Navigate to the Voice basic settings section.
  6. Click on the Line key Configuration link.
  7. Click on the More icon (three dots) for the top-most Line Appearance key. 
  8. Select Delete. This will delete the existing LAK.
  9. Click the + Line Appearance button.
  10. Select "Line appearance - User" from the dropdown list.
  11. Click Save in the Line appearance pop-up window. This will create a new LAK below any existing LAKs.
  12. Repeat steps 7-11 until all of the existing LAKs have been replaced.
  13. Click Save in the Edit device settings pop-up window.
  14. After replacing all of the existing LAKs, the line key configuration should successfully save.

Cause

The SubscriptionID associated with the existing Line Appearance Keys is missing. Re-creating them generates the correct SubscriptionID.