Symptom
You may have phones that exhibit issues outlined below if you have a Netgear router (typically the Nighthawk series):
- Incorrect Call Routing
- Ring groups not ringing all phones
- Desk phones not ringing when 8x8 Work Desktop is
- Phones not staying connected and rebooting
- Connected phone shuffle
- Duplicate internal IP addresses on phones
Applies To
- Netgear routers
- Nighthawk series
Resolution
The purpose of this article is to provide a sample configuration. At the time of article creation, this device was in a known working state on the firmware used.
Keep in mind different firmware versions will interact with hosted VoIP services in different ways. While this device may be fully functional on the tested and/or current firmware version, it is possible newer revisions will cause disruptions in service or make a device fully compliant with the required settings for hosted VoIP services where it was previously not.
Keep in mind different firmware versions will interact with hosted VoIP services in different ways. While this device may be fully functional on the tested and/or current firmware version, it is possible newer revisions will cause disruptions in service or make a device fully compliant with the required settings for hosted VoIP services where it was previously not.
Firmware issues have been found on all Netgear Nighthawk devices causing issues with blocked UDP ports. The two most commonly used versions of the Nighthawk routers have been tested with findings below.
Netgear R6400v2 models on firmware versions newer than R6400v2-V1.0.2.60_10.0.44 will experience dropped calls and connectivity issues. The newer firmware revisions block outbound UDP connections on ports 1024-65535 at random.
Netgear R7000p models on firmware versions newer than V1.0.0.58_1.0.50 will experience dropped calls and connectivity issues. The newer firmware revisions block outbound UDP connections on ports 1024-65535 at random.
Port Forward 5060
- Under Advanced Setup select Port Forwarding/Port Triggering.
- Select Add a custom port and fill in the following fields:
- Service Name: (can be anything)
- Service Type: TCP/UDP
- External Starting Port: 5060
- External Ending Port: 5060
- Internal Starting Port: 5060
- Enter an Internal IP address outside of the DHCP range so that none of the devices are assigned this IP address
- Click Apply.
- After applying these settings, power cycle the phones to establish the new network connection.
Set NAT Security to Open and Disable SIP ALG
- Log in to the router and open NAT Security.
- Find WAN Settings under WAN Setup.
- Set WAN Security to Open and check the box to Disable SIP ALG.
- Click Save.
- This can result in ghost calls on port 5060. To prevent this, Port Forward 5060 to an unused IP address outside of your DHCP range, if possible.
Cause
Some Netgear routers have network address translation (NAT) issues when using 8x8 services.
The source of the issue is likely a Netgear NAT Routing Table with NAT settings secured. This is because 8x8 will send calls to your network, but without a unique port, all traffic will be routed randomly, or to only one phone.
Firmware issues have been found that cause connectivity issues and dropped calls on the R6400 and R7000 models.