Symptom
The dial pad in Microsoft Teams does not appear for users, even though all of the following have been verified:
- The Sync Now process has been completed successfully in the 8x8 Voice for Microsoft Teams admin portal.
- Sufficient time has passed since the initial Sync Now setup process was completed (up to 72 hours).
- Teams users appear normally in the admin portal.
- Recent admin portal sync log data in Users > Sync Now > Show Sync History displays no Fail status.
Important: Note that this is not the only reason that the Teams dial pad might not appear. The most common reasons for this to occur are:
- Provisioning sync in the Voice for Teams admin portal has failed in some way, even though the Sync appears to have succeeded, such as in the issue outlined in Dial Pad Does Not Appear, No Domains Activated in Voice for Teams Sync Log
- Not enough time has elapsed since a fully successful setup sync, to allow Microsoft to perform its own backend processing of the sync request. This can take up to 72 hours, and even longer when Microsoft experiences a more significant backlog.
Applies To
- 8x8 Voice for Microsoft Teams
- Microsoft Teams
Cause
This specific issue could simply be a result of the Calls app not being pinned for display to users in the Microsoft Teams app bar.
Resolution
There are two solutions to this specific issue:
- Users can manually add the option to Teams. This is a temporary solution, because this action does not permanently pin the Calls app to the app bar area.
- The Microsoft 365 service administrator can pin the Calling app for Teams users, to force it into permanent view.
(Users) Manually Add the Calls App to Teams
- Teams users must click on the ellipsis in the Microsoft Teams app bar.
- Then search for and click on Calls.
- If the dial pad still does not appear, the user may need to click on Dial a number to expand the dial pad.
(Administrator) Pin the Calling App for Teams Users
To permanently pin the Calls / Calling app to the Teams app bar:
- Open the Microsoft Teams admin center.
- In the left side panel, navigate to Teams apps > Setup policies.
- In App setup policies, click Global (Org-wide default) or whichever policy has been applied to Teams users.
- In Pinned apps, verify that the Calling app is not present.
- Click + Add apps.
- In Add pinned apps, search for Calling.
- Then click Add to add Calling to the list of apps you are going to pin.
- Note that if you've installed the 8x8 Voice for Microsoft Teams App, you can also search for that and pin it to the Teams user app bar.
- Click Add at the bottom of the Add pinned apps panel.
- If desired, click on Calling to highlight the app, then click Move up or Move down as needed to permanently position the app in the Teams app panel for users.
- Click Save to complete your change. Note: It could take a few minutes for the change to take affect, as Microsoft processes and applies the change.
- Users should log out of and log back into Teams to see the change.
- Click on the Calls app in the Teams app panel to open see the dial pad.
Note that users might need to click on Dial a number in Calls to expand the dial pad.