Unable to Activate Cisco 504G and 303 Phones

Updated: 04/23/2024

Symptom

Can't activate Cisco 504G and 303 Phones due to firmware not compatible with the new Certificate. This can happen if the phone was reset while on 7.5.2 firmware or lower.

Applies To

  • Cisco 504G and 303 Desk Phones

Resolution

Note: This product has reached end of life and may no longer be suppored by 8x8.
Upgrade firmware to 7.5.7 by following these steps:
  1. Download the Firmware Tool from Cisco software download page.
  2. Extract and run file spa50x-30x-7-5-7.exe
  3. Enter the IP Address of the phone and follow the prompts to complete the upgrade.
  4. After the upgrade, reboot the phone one last time and try activating the phone again
  5. If phone is not yet provisioned, see Provision Your Cisco SPA IP Phone.
Before updating, verify that the phone's firmware is at 7.5.2b. If the phone is on a lower firmware, update the phone first before completing this article. The file for firmware 7.5.2b can be found here on the Cisco software download page.

Cause

The certificate for legacy Cisco phones has expired and unfortunately the new Certificate is not compatible with firmware 7.5.2b.

Additional Information

  • For Cisco phones that have already been activated and are online, no action is necessary.
  • After updating and re-provisioning, phones may take up to 2 to 24 hours to respond. Unfortunately there is no status screen or indicator that will show when this is complete. Leave the phone connected and allow it time to provision.