Salesforce Integration: Field-Level Security Causes Call Search to Fail with Unknown

Updated: 10/07/2024

Symptom

The Unknown issue can have a number of causes.
This article is specific to the problem caused by administrator changes to object permissions in their Salesforce org.
There are two primary symptoms associated with this issue:
  1. When a call is made or received, the 8x8 integration for Salesforce will display call activity, but shows Unknown for all phone numbers instead of matching them with a known Salesforce object, such as a Contact.
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  1. When using the Search tab function in the 8x8 communication panel to look for a Salesforce entry, known Salesforce objects are not discovered, and the Search pane remains blank.
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Applies To

  • 8x8 Work Integration
  • 8x8 Contact Center Integration
  • Salesforce
  • Field-Level Security

Cause

One or more Salesforce object fields that require permission to be visible, such as the Contact Asst. Phone field, have been hidden from user profiles by a Salesforce administrator.
Specifically, the Field-Level Security > Visible setting of a required object field has been disabled.
In this case, the affected user will not be able to complete any search of Salesforce in the 8x8 communication panel.

Resolution

The Salesforce Administrator must locate and set the Field-Level Security of Visible for all of the required Salesforce object fields in the table below, for any affected Salesforce user profile.
The procedure for this is shown, below.
Important: It is not necessary to "un-hide" object fields (set Field-Level Security to Visible) for Salesforce profiles of users who do not have specific search types enabled in the 8x8 communication panel, under
Settings 
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 > Integrations > Salesforce.
For example:
  • If the Phone field is "hidden" in the Account object, but is Visible in Contact, and only Contact is enabled for search in the user's 8x8 comm panel, call recognition and Search will both succeed.
  • If the Phone field is "hidden" in the Account object, but is Visible in Contact, and both Account and Contact are enabled for search in the user's 8x8 comm panel, call recognition and Search will both fail.
So if users were to enable all Search Types, and even only one object field in the table below is hidden from them (Field-Level Security not set to Visible), all searches will fail.
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8x8 Salesforce Integration Supported Objects & Fields

The following specific Object fields require Field-Level Security to be set to Visible for search to succeed:
Object Field Label Field Name
Contact Name
Phone
Mobile
Home Phone
Asst. Phone
Other Phone
Fax
Email
Name
Phone
MobilePhone
HomePhone
AssistantPhone
OtherPhone
Fax
Email
Lead Name
Phone
Mobile
Fax
Email
Name
Phone
MobilePhone
Fax
Email
Account Account Name
Phone
Fax
Name
Phone
Fax
Opportunity Opportunity Name Name
Case Case Number CaseNumber

Procedure

  1. Log into Salesforce as an administrator with sufficient privileges to change object permissions.
  2. Click on the gear icon at the top-right and select Setup.
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  1. Search for and click on Object Manager, under Objects and Fields.
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  1. Click on the specific object you will be changing. In this example, the Contact object.
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  1. In Fields & Relationships, click on the specific field name you will be changing. In this example, the Asst. Phone field.
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  1. Click on View Field Accessibility.
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  1. In the Field Accessibility for Field drop-down menu, select the field you're changing.
  2. Under the Field Access column, click on the related setting of the user profile you are changing.
    • In this example, the Hidden link of the Standard User profile. In this example, our change will affect all users assigned to the Standard User profile in Salesforce.
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  1. Under Field-Level Security, check the Visible box (see below).
  2. Click Save to complete the change for this specific field.
  3. Complete this change for all other required fields in the table above.
Note: It isn't strictly necessary to make the field you're changing actually visible in the Page Layout: only that the Field-Level Security is enabled/Visible for this specific object field in this specific user profile.
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  1. Alert users who were logged in to Salesforce during the change that they must log out of and back into Salesforce for the changes to take effect.
  2. Finally, ensure that all users of the 8x8 integration for Salesforce have enabled the appropriate object Search Type settings in the 8x8 communication panel, under Settings
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     > Integrations > Salesforce.
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