SMS Campaign Registration Fails Brand Authentication

Updated: 10/18/2024

Symptom

When a publicly traded company attempts to submit the Your Brand form in 8x8 Admin Console > SMS on or after October 17, 2024, they experience a generic error which prevents them from completing the campaign registration process:
  • An unexpected error has occurred
NOTE: The specific issue outlined in this article applies only to customers who have selected Public Company in Your Brand > What type of legal form is the organization? No other company types are impacted.

Applies To

  • 8x8 Work
  • SMS Campaign Registration
  • Your Brand
  • Publicly Traded Companies

Cause

On Oct 17, 2024, The Campaign Registry added a new Your Brand verification form field for publicly traded companies called Brand Contact Email Address.
This specific issue occurs because the submitted form is currently missing the Brand Contact Email Address, which customers cannot fill until the root issue is addressed.
The Campaign Registry receives your completed Your Brand data on submission, and then rejects the submission based on that missing info, regardless of whether all other info submitted is viable.
NOTE: The Your Brand > Brand Contact Details > Support Email Address field may contain a different email address than the missing, currently invisible Brand Contact Email Address.

Resolution

8x8 is currently working on a permanent solution to this issue.
In the meantime if you experience this specific issue, please do the following:
  1. Create a Case with 8x8 Support
  2. Note that you are attempting to submit the Brand form in 8x8 Admin Console > SMS > Your Brand and are receiving an error.
  3. Provide your direct contact information.
  4. Provide your Brand Contact Email Address, even if it is the same as your Support Email Address.
IMPORTANT:
Email Access: You must have access to the emails sent to the valid address Brand Contact Email Address. This is because a two-factor authentication (2FA) must be performed from the email which The Campaign Registry will send to this address.
Email Spam Filtering: To avoid issues with spam filters blocking the above email message, you may need to unblock email sent from The Campaign Registry, at noreply@auth.campaignregistry.com.
8x8 engineering will complete and submit the Your Brand form for you.
  • An email will be sent to the submitted Brand Contact Email Address.
  • You must then perform a verification/authentication using the info in that email.
Once The Campaign Registry processes and approves the Brand, it should appear in 8x8 Admin Console > SMS as Verified, and you can then proceed to the next steps in the SMS campaign registration process.