Symptom
The dial pad in Microsoft Teams does not appear for a single user, even though all of the following have been verified:
- The Sync Now process has been completed successfully in the 8x8 Voice for Microsoft Teams admin portal.
- Sufficient time has passed since the initial Sync Now setup process was completed (up to 72 hours).
- Teams users appear normally in the admin portal.
- Recent admin portal sync log data in Users > Sync Now > Show Sync History displays no Fail status.
- Calls app is pinned for display to users in the Microsoft Teams app bar.
Important: Note that this is not the only reason that the Teams dial pad might not appear. The most common reasons for this to occur are:
- Provisioning sync in the Voice for Teams admin portal has failed in some way, even though the Sync appears to have succeeded, such as in the issue outlined in this article:
- Not enough time has elapsed since a fully successful setup sync, to allow Microsoft to perform its own backend processing of the sync request. This can take up to 72 hours, and even longer when Microsoft experiences a more significant backlog.
Applies To
- 8x8 Voice for Microsoft Teams
- Microsoft Teams
Cause
The phone number assigned to the user in the Admin Console may already be assigned in the Microsoft Teams admin center.
Resolution
The phone number assignment needs to be removed in Microsoft Teams
- In the 8x8 Voice for Teams admin portal, verify that the following line appears in the Teams sync logs:
- Set-CsPhoneNumberAssignmentSet-CsPhoneNumberAssignment -Identity "<username>" -PhoneNumber "<phonenumber>" -PhoneNumberType "DirectRouting"
- In the Microsoft Teams admin center, check the user and confirm that no phone number is assigned.
- Search for an existing assignment for that phone number.
- The user that the phone number is assigned to may not be visible in the web interface.
- The following powershell command can be used to search for the assignment:
- get-csonlineuser | where-object lineuri -like 'tel:<phonenumber>' | select userprincipalname, displayname
- Remove the existing assignment for the phone number.
- If the user that the phone number is assigned to is not visible in the web interface, the following powershell command can be used to remove the assignment:
- Remove-CsPhoneNumberAssignment -Identity <userprincipalname result from previous command> -PhoneNumber "<phonenumber>" -PhoneNumberType "DirectRouting"
- If the user that the phone number is assigned to is not visible in the web interface, the following powershell command can be used to remove the assignment:
- Once the existing assignment is removed, initiate a sync from the 8x8 Voice for Teams admin portal.