Internet Fax Internal Conversion Error

Updated: 08/29/2024

Symptom

Outbound fax attempts using 8x8 Work for Desktop or Online fail. After two to three minutes, the following error is received: Internal Conversion Error.

Applies To

  • 8x8 Work for Desktop
  • 8x8 Work for Web
  • Internet Fax

Resolution

Ensure Compatible Attachment

Supported Filetypes
BMP (Image) Bitmap Image File
CSV (Text) Comma-Separated Values
DOC (Text) Microsoft Word Document (Legacy)
DOCX (Text) Microsoft Word Document
DOTX (Text) Microsoft Word Template File
JPEG (Image) Joint Photographic Experts Group Image
JPG (Image) Joint Photographic Experts Group Image
ODT (Text) Open Document Text File Format
PCX (Image) Picture Exchange File
PDF (Text) Portable Document Format
PNG (Image) Portable Network Graphic
PPT Microsoft Power Point Presentation file
RAS (Image) SunOS Raster Graphic
RTF (Text) Rich Text Format
TIF (Image) Tagged Image Filet Format
TIFF (Image) Tagged Image Filet Format
TXT (Text) Standard Text Document
XLS (Spreadsheet) Microsoft Excel Binary File (Legacy)
XLSX (Spreadsheet) Microsoft Excel Binary File
XLT (Spreadsheet) Microsoft Excel Template File

Correct PDF Digital Signature

If you are familiar with working with digital signatures, a simple workaround is to remove the digital signature(s) and instead insert a signature image in the PDF on the appropriate line. Otherwise, proceed below for a detailed fix. This fix assumes a Windows environment. Select to download Adobe Reader.
  1. Open the PDF file in Adobe Reader or Acrobat.
  2. From the menu, select Edit > Preferences.
  3. From the left-hand menu, select Signatures.
  4. Under Identities & Trusted Certificates, select More. The Digital ID and Trusted Certificate Settings pop-up will open.
  5. Select Add ID.
  6. Select A new digital ID I want to create now, then select Next.
  7. Select Windows Certificate Store, then select Next.
  8. Enter your identity information, then select Finish.
  9. Close the Digital ID and Trusted Certificate Settings window.
  10. In the Preferences window, select OK.
  11. Save PDF file to apply changes.
  12. Add the attachment to your fax and send.
Note: It may take some extra time to prepare and send the fax, especially if the attachment is large.

Cause

One or more of the following is likely to be the case:
  • The attached file is not in a supported format. PDF is often the most reliable, so it is suggested that document attachments be converted to PDF before attempting fax. See supported attachment file types below.
  • The PDF file attachment may contain a digital signature that may not have a trusted valid certification, which can also create the issue.
Note that 8x8 Work faxing also has the current limitations:
  • Total fax size sent cannot be greater than 19 MB.
  • Maximum of 5 files per fax.
  • Maximum page count of fax attachment in fax email notification is 20 pages.
    • Internet fax notification with attachments are only available with faxes up to 20 pages (inbound only).
    • Any fax exceeding 20 pages can still be downloaded from 8x8 Work for Desktop or Web.
  • Must use 11 digits (1 + 10-digit phone number) for sending outbound fax. Not doing so may result in a Number is Incomplete error.