Error Occurs When Attempting to Install 8x8 Integration Package for Microsoft Dynamics

Updated: 11/04/2024

Symptom

When attempting to install the 8x8 integration for Microsoft Dynamics 365, you may receive an error message such as:
  • This app can't be installed because its packages aren't compatible with this environment.
  • You don't have permission to install or update this application.
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Applies To

  • 8x8 Integration for Microsoft Dynamics 365
  • Microsoft Dynamics 365
  • 8x8 Work
  • 8x8 Contact Center

Resolution

  1. Confirm that your licensing level for Microsoft Dynamics 365 is Enterprise or higher.
    • Professional-level licensing currently is not supported, but we are working to provide compatibility with it.
    • At this time there is no ETA for a beta or production release to address this.
  2. If the current Microsoft Dynamics 365 licensing is Enterprise or higher, verify that the person installing the integration has sufficient permissions assigned within the Microsoft environment.
  3. Confirm that your Microsoft Dynamics solution is Dynamics 365 Sales.

Cause

There are a few likely causes for these errors:
  1. The Microsoft Dynamics 365 licensing level is Professional, which is currently not supported.
  2. The person attempting to install the 8x8 integration does not have sufficient permission levels in Microsoft 365 to install the 8x8 integration.
  3. You are attempting to install the integration on an unsupported Microsoft Dynamics 365 solution. Currently we only support Dynamics 365 Sales and Customer Service. 
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Additional Information

Documentation links and a list of Requirements and Limitations for the 8x8 Microsoft Dynamics 365 integration can be found in Microsoft Dynamics CRM.