Unable to Activate Poly RealPresence Trio 8800

Updated: 03/25/2024

Symptom

When attempting to activate a Poly RealPresence Trio 8800, you see a login screen and cannot activate the device.

Applies To

  • Poly RealPresence Trio 8800

Resolution

To resolve this issue, set a generic base profile on the device before activating it.
  1. On a computer on the same network as the phone, browse to the phone’s IP address.
  2. Log in as Admin and enter the administrator password.
  3. Navigate to Simple Setup.
  4. Open the Base Profile section.
  5. Select Generic as the Base Profile.
  6. Click Save.
  7. Allow the phone several minutes to reboot.
  8. When the phone is back online, verify the login screen is gone.
  9. Continue on to activate your phone.

Cause

Certain Poly RealPresence Trio models are Lync or Skype for Business enabled (models with part numbers -018 and -019). These models require a Generic Base Profile to be set before they can successfully activate.