8x8 Work for Desktop Server Connection Does Not Work

Symptom

When attempting to log in to 8x8 Work for Desktop on a Windows computer, the following error message is received: Cannot establish connection server. Please check your Internet connection and try again.

Applies To

  • 8x8 Work for Desktop
  • Windows

Resolution

Make sure the Firewall setting is low/minimum.

Windows 7/8

Upgrade Internet Explorer browser to at least IE11, which allows Windows to meet required security standards. You should do this even if you do not use Internet Explorer as your primary browser.
Note: IE11 is not available for Windows 8, though it is available for Windows 7 and Windows 8.1.

Windows Vista

Upgrade Internet Explorer browser to at least IE11, which allows Windows to meet required security standards. You should do this even if you do not use Internet Explorer as your primary browser.
Note: Service Pack 2 required.

Windows XP

Use 8x8 Work for Web via any Internet browser except Internet Explorer (e.g., Firefox, Chrome, Safari, etc.).

Check TLS in IE

Navigate to Internet Options in IE and check if TLS 1.1 and 1.2 is enabled. See screenshot below.
vod-tls.png

Cause

Assuming your computer or network's ability to solidly access the Internet is established, this is likely due to the security requirements in the latest edition of the 8x8 Work for Desktop application. On your computer, at least one of the following is causing the issue:
  • Internet Explorer may not yet be upgraded to version 11, which allows Windows to meet the required security standards.
  • You are not running a version of Windows that is at least Windows Vista with Service Pack 2 or later (e.g., running Windows XP).