8x8 Voice for Microsoft Teams Sync Issue for New Users

Updated: 05/02/2025

Symptom

Newly-created 8x8 users who have been enabled for the 8x8 Voice for Microsoft Teams service are not synchronizing to the 8x8 Voice for Microsoft Teams admin portal, and are not displayed there.
This issue impacts only customers who create new Voice for Teams agents or users.

Applies To

  • 8x8 Voice for Microsoft Teams
  • Voice for Teams admin portal
  • User Sync

Resolution

IMPORTANT
If the Disable Sync option (noted below) is not visible in the Voice for Teams admin portal ServicesPBX tab, then manual PBX sync on your service is already disabled by defalt. This is expected! In this case, skip to the Toggling the MS Teams license in 8x8 Admin Console section below, and follow the Resolution instructions from there.
Note that by default, the Disable Sync option will not be visible to new 8x8 Voice for Teams customers.

Disabling Sync in the 8x8 Voice for Teams admin portal

  1. Log in to the 8x8 Voice for Microsoft Teams admin portal. A shortcut is provided to this service in 8x8 Admin Console.
  2. Select the Services tab.
  3. In the ServicesPBX tab, ensure that Sync is disabled. If it states that Sync is currently enabled for this service, then click the Disable Sync button to disable it.
  4. Click Save. The Disable Sync button should change to display Enable Sync.

Toggling the MS Teams license in 8x8 Admin Console

  1. Log in to 8x8 Admin Console if needed.
  2. Select Users.
  3. To the right of the affected user, select Edit (pencil icon).
  4. Scroll down to Services and permisions and click the Enable MS Teams integration toggle switch to disable the service option. The toggle switch should turn gray.
  5. Click Save.
  6. Wait ten (10) minutes.
  7. In the Services and permisions again, click the Enable MS Teams integration toggle switch to enable the service option. The toggle switch should turn blue.
  8. Click Save.
  9. Wait ten (10) minutes.
  10. The user should now appear in the 8x8 Voice for Microsoft Teams admin portal Users tab list.

Cause

8x8 engineering has identified a bug in the service, which is currently being worked on to resolve it as soon as possible.
This KB article will be updated once a permanent resolution is available.