Windows 11 Update Causing Call Quality Issues With 8x8 Work Desktop

Updated: 10/16/2024

Symptom

Following a user's Windows 11 update including feature version 24H2, their 8x8 Work for Desktop application begins to experience high latency that leads to call quality issues.

Applies To

  • Windows 11 version 24H2 on Windows 11 Enterprise and Winsows 11 Home
  • 8x8 Work for Desktop on Windows (8.17.3 build and previous versions such as 8.16 and 8.15)
  • New build of 8.17.4 is not impacted and was released on October 16, 2024. 

Resolution

* 8x8 has released a new build of version 8.17 of 8x8 Work for windows on October 16th 2024 that contains a patch for this issue. Downloading the latest version will resolve the call quality issue and is available for download or by selecting "help" and "check for updates" option inside the application. 
The new patched version of 8x8 work is labeled 8.17.4 . If you have build number 8.17.3 or prevouis version such as 8.16 or 8.15 please download the latest version to resolve this issue. 
* Preivous Alternative solutions are below:
Uninstall the Windows 11 24H2 update and return to Windows 11 update 23H.
To resolve this issue:
  1. First check the Windows Update version:
    1. Click on Start.
    2. Search for about your PCWindows Specifications and look for version 24H2.
 
24H2jpg.jpg
  1. Navigate to Start > Settings > System > Recovery.
  2. Click Go back in System recovery > Go back.
  
 

Alternative Workaround 

If an immediate workaround to this issue is required, users can instead log into 8x8 Work for Web in a supported web browser. For more information, see What is 8x8 Work for Web and how do I use it?

Cause

8x8 is currently investigating the root cause of this issue, as well as other possible alternate resolutions.