Unable to Access Billing Tabs in 8x8 Support Portal

Updated: 04/12/2024

Symptom

When you log in to My 8x8 as an account admin, you are not able to access the Billing tabs to view your billing statements or update your payment method, or you are unable to view the My 8x8 option in the application panel.

Applies To

  • 8x8 Admin Console
  • Editions and X Series

Resolution

Ensure that you have been given the correct Permissions within Admin Console. For the following steps, ensure you are logged in as the Primary Admin of the account.
  1. Log in to Admin Console.
  2. Select Menu > Roles & permissions > Assignments.
  3. Select Create Assignment.
  4. In Assign To, select the user who needs billing access. 
  5. In Role, select My8x8 Admin (default).
  6. Select the appropriate Scope
  7. Select Save.
An "Assignment saved successfully" banner will confirm that the user now has updated permissions. Have the user log out and log back into the 8x8 Application Panel. Access to My 8x8 should be restored.
If you are still unable to view these permissions, Create a Case with 8x8 Support.

Cause

Most often, users simply need to be assigned the needed role in Admin Console. The issue affecting users who are appropriately permissioned is under investigation.