Symptom
When attempting to query tasks using the 8x8 Contact Centre CRM API (WAPI), the request fails and returns the following error message:
<?xml version="1.0" encoding="ISO-8859-1"?> <WAPI> <REPLY STATUS="-1" ERROR_STR="Internal error" ERROR_CODE="0" /> </WAPI>
Applies To
- 8x8 Contact Centre CRM API (WAPI)
- Task Queries
Resolution
- Log in to Configuration Manager for Contact Centre.
- Select Integration.
- Select the CRM API tab.
- In the Used Identity dropdown, select a user.
- Select Save.
Cause
The issue arises because no Used Identity is set in the CRM API's configuration. The Configuration Manager UI may mislead users, as it displays a value from the list for the Used Identity field when the page is viewed, despite the setting not being active in the backend.