8x8 Contact Centre CRM API (WAPI) Returns An Internal Error When Querying For Tasks

Updated: 05/16/2025

Symptom

When attempting to query tasks using the 8x8 Contact Centre CRM API (WAPI), the request fails and returns the following error message:
<?xml version="1.0" encoding="ISO-8859-1"?>
<WAPI>
  <REPLY STATUS="-1" ERROR_STR="Internal error" ERROR_CODE="0" />
</WAPI>

Applies To

  • 8x8 Contact Centre CRM API (WAPI)
  • Task Queries

Resolution

  1. Log in to Configuration Manager for Contact Centre.
  2. Select Integration.
  3. Select the CRM API tab.
  4. In the Used Identity dropdown, select a user.
  5. Select Save.
cc_Configuration_Manager_integrations_crm_api.png

Cause

The issue arises because no Used Identity is set in the CRM API's configuration. The Configuration Manager UI may mislead users, as it displays a value from the list for the Used Identity field when the page is viewed, despite the setting not being active in the backend.