Symptom
When attempting to add Contacts there is an error that reads, "Error saving contact."
In the browser console Network logs there is an error:
{"httpStatus":"FAILED_DEPENDENCY","validationErrors":null,"message":"Could not create contact. addCompanyContact failed with error:com._8x8.contactapp.common.util.ContactAppException: Multi-PBX Customer: Please provide the contactSiteId (siteCustomerId) httpStatus:404"}
{"httpStatus":"FAILED_DEPENDENCY","validationErrors":null,"message":"Could not create contact. addCompanyContact failed with error:com._8x8.contactapp.common.util.ContactAppException: Multi-PBX Customer: Please provide the contactSiteId (siteCustomerId) httpStatus:404"}
Applies To
- Admin Console
- Contacts
Resolution
The user adding the contacts needs to be a Company Admin, and needs to have an 8x8 Work license. It is recommended that this not be the Primary Administrator. See the Additional Information section.
To add a Company Admin assignment to a user, see Role-based access control.
To add an 8x8 Work license to a user, see Assign services and permissions to the user.
Cause
Limitation of Primary Admin user profile.
Additional Information
We recommend having a separate user profile for the Primary Admin without a phone license. This is to avoid getting the wrong caller ID when using Auto Attendants, Ring Groups, or Call Queues. This is a known limitation if the Primary Admin is using a phone license.