Symptom
In the 8x8 Voice for Microsoft Teams admin portal, both the Teams and PBX sync fail with an error, as displayed in the recent Sync Jobs > Teams diagnostic log:
- ERROR: EXCEPTION (1): Code: Authorization_RequestDenied
This occurs even though the admin user running the manual sync process has one or more Microsoft administrator permissions required for performing maintenance syncs in the Voice for Teams admin portal:
- Teams Administrator
- Teams Communication Administrator
- Skype for Business Administrator
Applies To
- 8x8 Voice for Microsoft Teams
- 8x8 Voice for Microsoft Teams admin portal
- Sync Now
Resolution
In this case the a Microsoft Global Administrator may be required to run the manual Sync Now process. Once this has been successfully completed, non-Global Admin users should be able to successfully run subsequent sync jobs.
Cause
The authorization from the inital sync by the Global Admin was lost. Global Admin rights are required for the initial service setup phase. Subsequent syncs for the addition of new users typically require only one of the following: Teams Administrator, Teams Communication Administrator, or Skype for Business Administrator.
Additional Information
For more inforamation see Microsoft Teams Requirements.