8x8 Work Cannot Send or Receive SMS Messages

Updated: $date.format('MM/dd/yyyy', $newDate)

Symptom

Sending SMS messages appears as prohibited for a user, and inbound SMS messages fail to arrive.
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Applies To

  • 8x8 Work
  • SMS
  • 8x8 Admin Console
  • US, Canada, Australia

Cause

In general, the affected user(s) are likely not configured properly to enable sending and receiving of SMS messages. Please see the Resolution section, below.

Resolution

Check the following to verify the correct assignment of SMS to users who are experiencing the issue:
  • US and Canada customers who wish to use 8x8 Work for SMS messaging must have a valid, registered SMS campaign configured in 8x8 Admin Console. Campaign registration is not required for Australia customers.
  • US and Canada 8x8 Work users currently must have an X2 or higher license, and a local phone number must be assigned and enabled for SMS to send/receive SMS messages.
  • Australia 8x8 Work users can use SMS when they are assigned an X1 or higher license and they also have an Australia mobile number assigned and enabled for SMS.
  • Note that when SMS is enabled for a user, they must log out of 8x8 Work and log back in for Admin Console SMS enablement changes to take effect.

Not Supported for SMS

The following are not supported for sending or receiving SMS messages under any circumstance:
  • Phone numbers that are assigned to Service extensions, such as Auto Attendants, Call Queues, and Ring Groups
  • Toll-Free phone numbers
  • Lobby and Basic licenses
  • Voice for Teams users with temporary numbers set during the phone number port-in process. These users will not have SMS available as an option in the 8x8 Voice for Microsoft Teams: Microsoft Teams App until their port-in process is complete, and their non-temp phone number has replaced their temporary number.