Screen Pop Not Appearing in 8x8 Contact Center for Netsuite Integration

Updated: 05/13/2025

Symptom

After upgrading NetSuite to version 2014.2, Screen Pop no longer appears when using the 8x8 Contact Center for NetSuite integration.

Applies To

  • 8x8 Contact Center
  • Configuration Manger for Contact Center
  • NetSuite 2014.2
  • NetSuite Integration

Resolution

Make Screen Pop open in a new window.
  1. Log in to Configuration Manager for Contact Center.
  2. Select Integration.
  3. Select the Screen Pop tab.
  4. Under Window Properties, check the box for Open new window for screenpop.
  5. Select Save.
Screen Pop will now appear in a separate window.

Cause

Previously, when using the integration, NetSuite contact information was embedded in iframes within the same browser as the Agent Workspace. NetSuite 2014.2 no longer supports this behavior, and 8x8 Contact Center will instead have to be accessed in an entirely separate window.