Azure AD 8x8 Application Logout Generates Microsoft Error Code AADSTS750054

Updated: 03/27/2025

Symptom

When logging out of an 8x8 application, a Microsoft error message appears, displaying code AADSTS750054.
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Applies To

  • 8x8 Applications
  • Microsoft Azure
  • Single Sign-On

Resolution

To resolve this issue:
  1. Navigate to 8x8 Admin Console.
  2. Click on Home > Identity and Security.
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  3. Delete the currently-applied URL in Single Sign-On Integration (SSO) > Sign-out page URL. This is typically the same URL as the Sign-in page URL.
  4. Add the following URL in its place: https://login.microsoftonline.com/common/wsfederation?wa=wsignout1.0
  5. Click Save to complete the change.
  6. Test your logout functionality to confirm the fix.
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Cause

This issue can occur with 8x8 applications when both of the following apply:
  • Single Sign-On of 8x8 applications has been configured in both 8x8 Admin Console > Identity and Security and Microsoft Azure.
  • The tenant-specific (Microsoft-suggested) Azure SSO Logout URL has been applied to the 8x8 SSO configuration in 8x8 Admin Console.

Additional Information