Symptom
When logging out of an 8x8 application, a Microsoft error message appears, displaying code AADSTS750054.
Applies To
- 8x8 Applications
- Microsoft Azure
- Single Sign-On
Resolution
To resolve this issue:
- Navigate to 8x8 Admin Console.
- Click on Home > Identity and Security.
- Delete the currently-applied URL in Single Sign-On Integration (SSO) > Sign-out page URL. This is typically the same URL as the Sign-in page URL.
- Add the following URL in its place: https://login.microsoftonline.com/common/wsfederation?wa=wsignout1.0
- Click Save to complete the change.
- Test your logout functionality to confirm the fix.
Cause
This issue can occur with 8x8 applications when both of the following apply:
- Single Sign-On of 8x8 applications has been configured in both 8x8 Admin Console > Identity and Security and Microsoft Azure.
- The tenant-specific (Microsoft-suggested) Azure SSO Logout URL has been applied to the 8x8 SSO configuration in 8x8 Admin Console.
Additional Information
For more information, see Azure AD: 8x8 Single Sign-On (SSO) and User Provisioning (SCIM) Configuration.