8x8 Contact Center for NetSuite closing and redirecting

Updated: 07/03/2025

Symptom

When an agent attempts to log in to 8x8 Contact Center for NetSuite for the first time, the integration closes and then prompts for the URL to be re-entered. On subsequent logins, the MaPanel opens briefly before closing, and upon reopening, the newer Mashell integration is presented.

Applies To

  • 8x8 Contact Center for NetSuite 3.1

Resolution

This behaviour is expected as part of the migration process from MaPanel 1.0 to MaPanel 2.0 (Mashell) integration. If you wish to avoid this initial flip process, you can directly use the MaPanel 2.0 CTI in your NetSuite instance.
To use the MaPanel 2.0 CTI directly, navigate to the following URL: https://cloud8.8x8.com/mashell/public/netsuite-au.html?nextGen=true&env=netsuite-au
  1. From the menu bar at the top of the NetSuite Home screen, hover over Customization.
  2. From the Customization drop-down list, select Lists, Records, & Fields > Record Types
  3. From the Record Types page, click the 8x8 netsuite record. The record opens. 
  4. Click More from the upper right side of the Custom Record Type page.
  5. Select View Records. The 8x8 netsuite record List page displays. 
  6. Click Edit.          
  7. On the 8x8 Netsuite record page, locate the 8x8 Production link and ensure the following link is used: https://cloud8.8x8.com/mashell/public/netsuite-au.html?nextGen=true&env=netsuite-au
  8. Click Save

Cause

The automatic migration of first-time users from the legacy MaPanel 1.0 integration to the newer MPanel 2.0 (Mashell) integration. This migration necessitates re-entering the 8x8 Contact Center URL because the NetSuite CTI does not automatically retain the 8x8 Contact Center domain during this transition.