Question

Which Integrated Call Control headsets does 8x8 Support for use with 8x8 Work and Meetings?

Applies To

  • 8x8 Work for Desktop v 6.5 and later
  • Jabra, Poly, and Sennheiser Headsets

Answer

Warning! Use of software (such as Poly Hub Desktop) that also controls user’s headset may interfere with 8x8 Work Desktop. To ensure proper functioning of integrated call controls with 8x8 Work Desktop, turn off any conflicting software. Alternatively, you can disable integrated call control feature from 8x8 Work Desktop settings.
In addition to this basic functionality, 8x8 Work for Desktop v 6.5 and above supports Integrated call control. Integrated call control functionality allows users to answer, hang up or mute calls using the buttons on the headset. This functionality is available only for USB headsets from Jabra, Poly or Sennheiser. Bluetooth headsets with a USB dongle are also supported.

Supported Headsets for Integrated Call Control

Important! Integrated call control for wireless headsets require headsets to be connected via the USB dongle provided by the vendor. Bluetooth headsets that directly connect to computer Bluetooth are not supported.

Poly (Formerly Plantronics)

  • Blackwire C325, C725
  • Voyager 5200
Alternatively, use the products Finder on the Poly website by choosing; How do you primarily plan to use the device > Joining meetings, calling colleagues > headset > Open Office or Quiet office/home office > PC & mobile phone. Select a device that is wired or Bluetooth with a USB accessory that connects to the desktop.

Jabra

  • Jabra Evolve 40 
  • Jabra Evolve 75
  • Jabra Evolve 65t
  • Engage 75
  • Engage 50
  • Speaker 710
Search on the Jabra website for Headsets > Office headsets, Headsets > Call Center headsets, Business Solutions > Unified communications to find a wired headset or a Bluetooth headset with a USB dongle accessory.

Sennheiser

  • PC-7 USB Headset
  • PC-8 USB Headset
Alternatively, choose a wired or wireless or Bluetooth headset with a USB dongle Sennheiser website.

Question

Which headsets are compatible with 8x8 Work?

Applies To

  • Headsets
  • 8x8 Work

Answer

8x8 Work works with any standard headset for basic audio operations. 8x8 Work supports advanced, integrated, call control operations such as answer, hang up or mute using the buttons on the headset.

Objective

Forward calls or enable call forwarding on Poly VVX series handsets.

Applies To

  • Poly VVX 300 series

Procedure

It is possible to forward an incoming call to a number or set the phone to forward all incoming calls to a number.

Forward an incoming call

  1. On the Incoming Call screen, select Forward.
  2. Enter the number and select Forward.

Forward all incoming calls

  1. On the Home Screen, select Forward.
  2. If you have more than one line, select a line.
  3. Choose either Always, No Answer, or Busy.
  4. Enter a contact’s number, and select Enable.
If you chose No Answer, you can enter the number of rings before the call is forwarded.

Disable call forwarding

  1. On the Home Screen, select Forward.
  2. If you have more than one line, select a line.
  3. Choose your forwarding type and select Disable.

Objective

Find all the possible volume adjustment locations when using Poly Headsets.

Applies To

  • Poly CS5xx
  • Savi 7xx
  • Savi 8xxx

Procedure

Identify which headset is paired to the base and refer to numbered guide for details.
Headset2..png
Headset Numbered Guide
  1. Volume control [ Increase | Decrease ]
  2. Call control [ Call, Hold, End]
  3. Mute ( *Press volume button )
  4. Power Button
  5. Active Noise Cancelling
Identify which base is paired to the base and refer to numbered guide for details.
SAVI700.8200.Base.png
CS510.520.Base.png
Headset Base Numbered Guide
  1. Microphone Volume Control
  2. Speaker Volume Control
  3. Configuration Switch

Known Issues

  • Setting the Microphone Volume level(1) too high on headset base can cause echo while using the paired headset.
  • Setting the Speaker Volume level(2) too high on headset base will cause audio to sound muffled. 
  • Most phones work on Configuration Switch(3) position A, adjust this if you cannot hear the dial tone clearly.
  • There is a known issue with EHS and Poly VVX firmware 5.9.1.0615

Question

Which Plantronics headsets are compatible with my phone?

Applies To

  • Plantronics Headsets

Answer

8x8 desk phones support the use of a number of popular business-oriented headsets. Plantronics has created a Compatibility Guide to see which Plantronics headsets will work with your 8x8 desk phone.
To view a list of compatible headsets, click here and search for your device model.
Note: This tool is provided and maintained by Plantronics, Inc. 8x8 cannot verify its function or accuracy. For questions about Plantronics products, refer to Plantronics documentation and support directly.

Question

What phones are compatible with 8x8 services?

Applies To

  • Softphones
  • Desk Phones
  • Headsets
  • Routers
  • BYOD

Answer

For a current list of compatible devices, see the Devices page on our main web site.

Symptom

No audio from headset after 8x8 Work for Desktop update.

Applies To

  • Plantronics Headsets
  • 8x8 Work for Desktop

Resolution

  1. In 8x8 Work for Desktop Settings, ensure Enable built-in call controls is disabled. Do not enable if you use any other software that also controls the headset (e.g., Plantronics Hub).
    clipboard_ea1d0f2726af204c9888099d8e2e28d9b.png
  2. Make sure the selected Microphone / Speakers entry listed from Plantronics is working. If there are two, try them in sequence.
    clipboard_eade9f987c49e1c52b1dd09c9ab702705.png

Cause

Following an update to Work for Desktop, the selection of the Plantronics headset may need to be reviewed if no audio is heard from the headset into the app. Note that support for the Plantronics Hub was discontinued for 8x8 Work for Desktop with version 7.17 and above.